Recipient missing on invoice after using Skip activities


Summary:

This article applies to a scenario where an invoice is in Workflow with Recipient missing and the action Skip activities has been used on the invoice.

When Skip Activities is used and the selected next activity is a workflow activity, then the workflow task is created without a recipient and the invoice will show up as Recipient missing.

 

Cause:

In the invoice process the recipient resolving for the next activity requires information about the current activity and the current user. This information is not available when activities are skipped and therefore recipient cannot be resolved.

   

 

Checklist:

The impact of this issue depends on which activity has been selected as next activity. For activities where recipient resolving is not required, like Transfer, there is no impact.

If the next activity is a workflow activity, like Header review or Row approval, then the corresponding task is created without recipient.

 

Instructions:

The solution depends on which activity has been selected as next.

1) If the next activity is a Workflow header activity, like Header review or Header approval, then the task recipient can be selected from the Workflow screen.

For the invoice in question, user has performed Skip Activities action. When activities are skipped, then the recipient resolver is not triggered and the invoice task is created without recipient. To resolve the issue with this invoice, please select Edit tasks action from the invoice Workflow screen. Then select the correct recipient for the workflow task and save the invoice. The task is forwarded to the selected user.

  1. On the Workflow screen click Edit tasks.
     
  2. Select the correct recipient and save the invoice.

    Or you can use the recipient picker.

     
  3. Task is forwarded to the selected recipient.
     
  4. And this is also visible in the invoice history.
     

2) If the next activity is a Workflow row activity, like Row review or Row approval, then the task recipient cannot be selected from the Workflow screen.

As the invoice is currently in row approval, the task recipient cannot be changed from the invoice Workflow screen. To resolve the issue with this invoice, please select another recipient from the coding row Recipient field. Then select the correct recipient again and save the invoice. The task is forwarded to the selected user.

  1. The recipient on the coding needs to be re-selected to trigger the row task recipient assignment.
     
  2. First select another recipient.
     
  3. Then select the correct recipient again. Save the invoice.
     
  4. After this action the task is assigned to the correct recipient.
     
  5. The row will show that it has been forwarded.
     
  6. And also the invoice history will reflect the same.