P2P - IP - BTIPC Import not working


Summary:

BTIPC import is not working (although the service is running) and in the IPImport.log file, the below error is being logged:

“OpenConnection Opening database connection. ConnectionString: DSN=eflow, UserId: sa, Password:

-2147467259 OpenConnection [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified Failed to open database connection.”

Cause:

This can happen when urlsave.tmp file gets locked . This can be identified by the timestamp of the urlsave.tmp file. The timestamp will most likely correspond to the timestamp of the last successful transfer.

urlsave.tmp is a temporary file created in BTIPC. This file stores the link to bturl.ini file which has the  details to both the IP DB and the BT connection.


Resolution:

Rename the urlsave.tmp file and re-start the BTIPC service. The BTIPC import should work now.