Procurement - How to - Troubleshoot tax code returned from external webshop


Summary:

Scenario where faulty tax code is returned from external webshop or Marketplace to AP Procurement is reported by the customers every now and then. This article explains how the tax code is resolved in this process and how to proceed with the troubleshooting.

 

Cause:

Tax code is resolved by the tax percentage value that is returned from the external webshop or Marketplace. It is resolved when the requisition is created. If system cannot resolve the tax code, it needs to be selected by the users manually.

 

For legacy external webshops (ISE not in use) tax percentage can be returned from for example in OCI field NEW_ITEM-CUST_FIELD1. Tax percentage is used for resolving the Tax Code if the Purchasing Category has a default Tax Code defined​.

 

In Marketplace integration both of these OCI fields can be used for resolving the tax code:

Note that since version 24.6 Marketplace tax category and tax percentage can be skipper in tax code resolving. Read more about the feature from:

Marketplace tax category and tax percentage can be skipped in tax code resolving

 

Checklist:

Troubleshoot by replicating the issue using the same problematic products. Use developer tools to see the values that are returned to AP Procurement when the basket is transferred. More information about this troubleshooting method can be found from: BWKB0018306: Procurement - How to - Technical configuration and data transfer for external webshops.

 

Resolution:

If a faulty or empty tax code is resolved, troubleshoot the transferred OCI fields to see if that value matches with the purchasing categories' data or with the tax codes' data in P2P Admin.