Purchase Order Discrepancies Between SAP and AP Automation.


Issue: Purchase Order Discrepancies Between SAP and AP.

Description:

Customers occasionally encounter discrepancies where the Purchase Order (PO) in AP does not update according to the corresponding SAP PO records. Customers may observe that the PO in SAP shows different values than what is reflected in AP. Even after performing a PO refresh or initiating the PO import process, the PO in AP still does not match the values in SAP.

Root Cause:

This issue typically occurs when there is an external, manual matching process for the PO on the customer’s SAP system.

Explanation of the Behavior:

1) PO Not Yet Involved in Matching in AP: If a PO with external associations in SAP is imported into AP and has not yet been involved in any matching process on AP side, then any changes or reversals (such as manual external matching or un-matching) made in SAP will be reflected in AP during the next PO update or refresh.

2) PO Already Involved in Matching in AP: However, if the PO has already been processed in the matching process within AP, then any subsequent changes or reversals made manually on the SAP side (such as modifications to the PO row or Goods Receipt) will not be reflected in AP. This misalignment between the systems is the root cause of the issue.

 

Resolution Process:

In cases where the PO data in AP does not align with SAP, Basware Support will need to manually update the PO records in AP to match the SAP records. This will be done by the CR Center team with customer approval and the request should be processed as a Change Request (CR), must be treated as billable CR. 

 

 

Steps:

 

1) Customer Action: To proceed, the customer must provide the PO Number that should be updated.

 

2) Basware Support Action: Once the required details are provided and CR confirmation is received from customer, Basware Support will raise a RITM with the necessary DB queries to update the records in the AP system to match the SAP data, according to standard Change Request process.

 

3) Approval Process: The updates will be performed directly on the AP database and will require approval from the R&D team before execution.

 

 

Recommendations:

To prevent similar issues in the future, we strongly recommend to ensure that any PO that has at least one invoice matched in AP to be matched further only in AP, or that the PO is imported to AP after any external changes in SAP.